top of page
  • paulcapatana

IS-IS – Route redistribution between areas

In previous tutorial we described how IS-IS protocol works and how it can be configured.

For todays exercise we’ll have the situation where we need to configure two separate areas and to make sure that there is connectivity between them.


How should we proceed to reach our goal ?


We’ll see that the answer is a rather simple one and easy to apply when we’ll reach the end of this tutorial.

Now in the previous tutorial we’ve learned that there are two methods of configuring the IS-IS protocol : one method uses the L2 address also called MAC address , the other one is using the L3 address also called IP address .

For the sake of simplicity for this exercise we’ll choose the configuration mode where we’ll use the L2 address


For our purpose we’ll use the below topology


First we need to make an IP addressing plan and to configure the interfaces as shown in below table


R1

interface Loopback11

ip address 11.11.11.11 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.20.10.1 255.255.255.252

ip router isis

isis circuit-type level-2

no shutdown

!

interface GigabitEthernet1/0

ip address 172.16.10.1 255.255.255.252

ip router isis area1

isis circuit-type level-2

no shutdown

R2

interface Loopback22

ip address 22.22.22.22 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.20.10.2 255.255.255.252

ip router isis

isis circuit-type level-2

no shutdown

!

interface GigabitEthernet1/0

ip address 172.20.20.1 255.255.255.252

ip router isis

isis circuit-type level-2

no shutdown


R3

interface Loopback33

ip address 33.33.33.33 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.20.1.1 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

!

interface GigabitEthernet1/0

ip address 172.20.20.2 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

!

R4

interface Loopback44

ip address 44.44.44.44 255.255.255.255

ip router isis

!

interface GigabitEthernet0/0

ip address 172.20.1.2 255.255.255.252

ip router isis

isis circuit-type level-2-only

no shutdown

!

interface GigabitEthernet1/0

ip address 172.16.1.1 255.255.255.252

ip router isis area1

isis circuit-type level-2

no shutdown

!

R5

interface Loopback55

ip address 55.55.55.55 255.255.255.255

ip router isis area1

!

interface GigabitEthernet0/0

ip address 172.16.30.1 255.255.255.252

ip router isis area1

isis circuit-type level-2

no shutdown

!

interface GigabitEthernet1/0

ip address 172.16.10.2 255.255.255.252

ip router isis area1

isis circuit-type level-2

no shutdown

!

R6

interface Loopback66

ip address 66.66.66.66 255.255.255.255

ip router isis area1

!

interface GigabitEthernet0/0

ip address 172.16.30.2 255.255.255.252

ip router isis area1

isis circuit-type level-2

no shutdown

!

interface GigabitEthernet1/0

ip address 172.16.1.2 255.255.255.252

ip router isis area1

isis circuit-type level-2

no shutdown

!



Now that we’ve configured every interface as shown above let’s proceed further routing protocol configuration as shown below using the MAC address of the physical interface


R1

router isis

net 49.0001.ca01.0566.0008.00

is-type level-2

log-adjacency-changes

!

router isis area1

net 46.0001.ca01.0566.001c.00

log-adjacency-changes

is-type level-2


R2

router isis

net 49.0001.ca02.0576.0008.00

is-type level-2

log-adjacency-changes


R3

router isis

net 49.0001.ca03.0586.001c.00

is-type level-2

log-adjacency-changes


R4

router isis

net 49.0001.ca04.0596.0008.00

is-type level-2

log-adjacency-changes

!

router isis area1

net 46.0001.ca04.0596.001c.00

log-adjacency-changes

is-type level-2


R5

router isis area1

net 46.0001.ca05.05a6.001c.00

log-adjacency-changes

is-type level-2


R6

router isis area1

net 46.0001.ca06.05b6.001c.00

log-adjacency-changes

is-type level-2



Now that we’ve done all these configurations ,let’s step back for a second and let’s have a look at the routing tables related to R3 and R5 routers




As you probably noticed these routers are unaware of each other’s routes.

Why ? Because these routers are located in different areas and at least for the moment there is no communication between these areas

Do we need to enable the communication between them ?

If the answer is yes let’s do some networking magic and we’ll see how the situation will look after that 😊


We’ll need to make some small configuration changes only on R1 and R4 routers in order to enable the route redistribution between areas

R1

R4



After making that small configuration change it’s the right time to have another look at the routing tables related to R3 and R5 routers:




From these screenshots we are seeing that these routers now have knowledge about each other

Last step is to check the bidirectional connectivity between them using ping command


From this capture we saw that R5 is reaching R3 via R1




R3 is also reaching R5 via R1 so we have symmetric routing which is perfect


And job done , all good , we managed to enable the connectivity between these areas

I hope that now you see why I said at the beginning that solution for this kind of change is simple

I also hope that this document has been informative and helpful for you 😊

9 views0 comments

Recent Posts

See All
Post: Blog2_Post
bottom of page